Not a member yet? Why not Sign up today
Create an account  

Welcome, Guest
You have to register before you can post on our site.

Username/Email:
  

Password
  





Search Forums

(Advanced Search)

Latest Threads
Nice quotes for a better ...
Forum: General Discussion
Last Post: tropic
22-07-2017, 02:19 PM
» Replies: 46
» Views: 4,854
XanMod Kernel
Forum: Releases
Last Post: tropic
22-07-2017, 02:14 PM
» Replies: 302
» Views: 51,615
4.9.37-xanmond44 - unable...
Forum: Bug Report
Last Post: tropic
16-07-2017, 09:50 AM
» Replies: 1
» Views: 36
4.12 Memory allocation is...
Forum: Bug Report
Last Post: tropic
16-07-2017, 08:28 AM
» Replies: 5
» Views: 96
Brainstorming for XanMod ...
Forum: Development
Last Post: Gsus
14-07-2017, 08:48 PM
» Replies: 69
» Views: 6,607
The new ISO of Orvitux Gn...
Forum: Releases
Last Post: Guest
13-07-2017, 05:52 PM
» Replies: 3
» Views: 79
Laptop-mode config needs ...
Forum: General Discussion
Last Post: tropic
12-07-2017, 03:18 PM
» Replies: 7
» Views: 111
VMWare Kernel Module Upda...
Forum: General Discussion
Last Post: HougeLangley
12-07-2017, 01:09 PM
» Replies: 9
» Views: 713
Kernel panic after start ...
Forum: Bug Report
Last Post: figue
10-07-2017, 08:39 AM
» Replies: 3
» Views: 47
BFQ may not ready for the...
Forum: General Discussion
Last Post: Xan
10-07-2017, 03:01 AM
» Replies: 5
» Views: 127

 
Forum Statistics

Members: 77,   Latest member: michaelmcde,   Forum threads: 91,   Forum posts: 2,020,   Full Statistics


  4.9.37-xanmond44 - unable to boot - HT issue [closed]
Posted by: LTM - 16-07-2017, 03:48 AM - Forum: Bug Report - Replies (1)

Hi,

Just tried to boot with kernel : 4.9.37-xanmond44 and it is not booting.

I disabled HT and now it`s working.
Print screen bellow:
https://www.dropbox.com/s/emjm3o5meu4gpl...M.png?dl=0

Print this item

  4.12 Memory allocation issue
Posted by: LTM - 14-07-2017, 10:45 PM - Forum: Bug Report - Replies (5)

Hi,

I have installed the latest 4.12 kernel on 9 dedicated servers.
it seems that there is an issue with the memory allocation (we have this problem now on 2 servers).
After running without any issues for about 12h, the server goes to swap (it uses for no reason 50% of the ram)
I have shut down every process and it still uses 50% of the ram (256gb out of 512gb).

free
              total        used        free      shared  buff/cache   available
Mem:      528133752   262913284   263759632       42624     1460836   262092052
Swap:      15625212           0    15625212

Print this item

Smile The new ISO of Orvitux Gnu/Linux 2016.1 it's available for download [w/ XanMod]
Posted by: orvitux - 13-07-2017, 04:00 AM - Forum: Releases - Replies (3)

[Image: 19875362_1486099331451559_39591402980109...e=5A089179]


Estamos estrenando nueva ISO,Orvitux Gnu/Linux 2016.1 actualizada,recuerden este no es un nuevo lanzamiento o versión,esta imagen iso es ideal para todos aquellos usuarios que desean o bien instalar desde cero el sistema o bien re-instalarlo ni tener que descargar todas las actualizaciones acumuladas hasta la fecha,contiene algunas novedades como xanmod kernel 4.10.17, se remplazo mate desktop con la versión mas reciente de budgie desktop. Zswap + Compresión lz4 ya viene activados desde el inicio del sistema,tambien si eres un fan de la shell o consola estás de suerte,Byobu esta añadida en esta ISO ,vas a poder añadir una larga lista de funcionalidades, como la divisón de pantalla, ejecución de programas en el fondo, organización de programas en pestañas y muchas más cosas increíbles.Bueno tambien esta presentes como apt-p2p, prelink, preloand, Wajig y muchas mas en sus versiones actualizadas. Que esperas para descargarla ya visita nuestra pagina ahora.

http://orvituxgnulinux.tk/
http://orvitux.blogspot.com.es/
https://es-es.facebook.com/ORVITUX/
https://sourceforge.net/projects/orvitux-gnu-linux/
https://www.youtube.com/watch?v=y3Hj7svha9I

Deja atrás tu configuración genérica prueba nuestro sistema.

------------------------------------------------------------------------------------------------------------------------------------------------------

We are in the new ISO, Orvitux Gnu / Linux 2016.1 updated, remember this is not a new release of the version, this image is ideal for all users who want to either install the system from scratch or re-install it or have to download all The updates accumulated to date, contains some new features like the kernel of xanmod 4.10.17, will replace matte the desktop with the latest version of budgie desktop.Zswap + Compression lz4 is already active from the start of the system, also if you are a Fan of the Shell or console you are lucky, Byobu is added in this ISO, it is a power to add a long list of features, such as screen division, running programs in the background, organizing tab programs and many more Incredible things. Also this presents as apt-p2p, Prelink, Preludio, Wajig and many more in their updated versions. You wait to download it and visit our page now.

http://orvituxgnulinux.tk
http://orvitux.blogspot.com.es/
https://es-es.facebook.com/ORVITUX/
https://sourceforge.net/projects/orvitux-gnu-linux/
https://www.youtube.com/watch?v=y3Hj7svha9I

Leave your generic configuration behind, try our system.

Print this item

  Laptop-mode config needs adjustments for xanmod!
Posted by: GWD72 - 11-07-2017, 08:50 AM - Forum: General Discussion - Replies (7)

Hello forum followers!

I thought it could be useful to notify here that laptop-mode users need to make some changes to the /etc/laptop-mode/laptop-mode.conf file in order that it will continue the enhancements offered by xanmod kernels!

I am currently using 4.11.9-xanmod13.

The config for laptop-mode can now be identified as blocking the dirty_ratio and dirty_background_ratio (for example) implemented by xanmod (although this can be fixed).

To the point, what I changed and noticed improvements which were most apparent on my HP mini 210-1000:

1) XFS_HZ=500 (default was 100) NOTE: I assume this is the same frequency as that by which the xanmod kernels are compiled.  If this is WRONG, no problem for me, do make corrections please!

2) CONTROL_MOUNT_OPTIONS=0 (default was 1) NOTE: this disables laptop-mode changing tuned fstab mount options (I use my own mods and was previously oblivious to the fact that my tweaks were being over-riled by laptop-mode tools).

3) LM_DIRTY_RATIO=20  (default was 40)
    NOLM_DIRTY_RATIO=20  (default was 60)

4) LM_DIRTY_BACKGROUND_RATIO=5  (default was 1)
    NOLM_DIRTY_BACKGROUND_RATIO=5  (default was 10)

5) CONTROL_HD_IDLE_TIMEOUT=0   (default was 1)

6) CONTROL_NOATIME=0  (default was 0 or 1)
    USE_RELATIME=0  (default was 0 or 1)
NOTE: I use noatime in mount options specified in fstab.  If you do not want laptop-mode tools to meddle with your fstab mount options, turn these off also (i.e. use a value 0) and see 2) above.

7) CONTROL_READAHEAD=0  (default was 1)

NOTE:  one needs to think about other systems settings on "their" environment and not blindly follow this since each system/box can and will be set up differently.  I accept no responsibility for anyone using the settings I found helped me!

I need to survey further with more usage, but making these changes seems to allow xanmod to do its thing performance-wise while still observing decent battery savings.  Of course, "you" may find a different end result.

In addition, there are some further tweaks I think could be made, and perhaps those associated with xanmod could comment?

For example, these following values are defaults in the laptop-mode config file, but I've no idea if they match those of the native 4.11.9-xanmod13:

#
# kernel default settings -- don't touch these unless you know what you're
# doing.
#
DEF_UPDATE=5
DEF_XFS_AGE_BUFFER=15
DEF_XFS_SYNC_INTERVAL=30
DEF_XFS_BUFD_INTERVAL=1
DEF_MAX_AGE=30

Are these values xanmod uses, or, should they be adjusted in order to match?

Print this item

  Kernel panic after start any Virtualbox VM [solved]
Posted by: figue - 09-07-2017, 10:31 PM - Forum: Bug Report - Replies (3)

Hi, I'm running 4.12 xanmod on Archlinux. I use default xanmod config and build with default GCC 7.1.1.

A kernel panic happens when I try to boot any Virtualbox VM. With Arch stock kernel or xanmod 4.11.x series all is OK.

I can only take a photo of the kernel panic (please excuse the quality).

http://imgur.com/Vsn800w

Thanks

Print this item

  BFQ may not ready for the production environment
Posted by: HougeLangley - 09-07-2017, 04:52 AM - Forum: General Discussion - Replies (5)

These days I noticed that many things about the new I/O Scheduler. 

The first one, BFQ not default in the new version kernel 4.12. We should use a litter trick. I see one way from here. And the best way is using Xanmod kernel. BTW, Thank you, Xan.

The second one. A benchmark test I have been noticed from Phoronix site. BFQ and Kyber I/O scheduler not good enough in those tests. What do you guys think these tesets?

The third one, BFQ not stable for now. I think you guys have been noticed that the re-new version xanmod kernel. For now, I using mq-deadline instead of BFQ and Kyber. I found if edited the /etc/default/grub like this:


Code:
GRUB_CMDLINE_LINUX_DEFAULT="scsi_mod.use_blk_mq=1 elevator=mq-deadline zswap.enabled=1 zswap.compressor=lz4"

After I boot and check io scheduler. The default one is BFQ. So, I edited /etc/rc.local and using .sh file to changed default io scheduler after boot. My .sh file like this:


Code:
#!/bin/bash
echo mq-deadline > /sys/block/sda/queue/scheduler

After boot and check it.


Code:
hl@hl-Inspiron-15-7000-Gaming ~ $ cat  /sys/block/sd*/queue/scheduler
[mq-deadline] kyber bfq none
[mq-deadline] kyber bfq none
hl@hl-Inspiron-15-7000-Gaming ~ $


Any idea changed the defalut io scheduler using better way. Thank you.

Print this item

  Xanmod 4.11.6-10 running beautifully on...
Posted by: GWD72 - 24-06-2017, 10:35 AM - Forum: General Discussion - Replies (1)

1. HP mini-210 - running 64-bit Atom N450 @ (max.) 1.67 GHz (2-threads), 2 GB ram, Lubuntu 16.04 LTS and 4.11.6-xanmod10 x86_64 with (amongst others) zram, preload, intel microcode.

2. HP Eitebook-2560p - running 64-bit i5-2410M @ (max.) 2.90 GHz (4-threads), 8 GB ram, Ubuntu 16.04 LTS and 4.11.6-xanmod10 x86_64 with (amongst others) preload, intel microcode, firecuda 1TB (hydrid).

3. DELL e6230 - running 64-bit i5-3340M  @ (max.) 3.40 GHz (4-threads), 8 GB ram, Ubuntu 1604 LTS and 4.11.6-xanmod10 x86_64 with (amongst others) preload, intel microcode.

All using bfq, and many of the recommended tweaks (found in this forum).

Print this item

  vm settings question
Posted by: GWD72 - 23-06-2017, 01:41 PM - Forum: General Discussion - Replies (4)

Hello forum followers!!

I have a question about the "vm" settings using 4.11.6-xanmod9.

Prelude: I have assumed (perhaps incorrectly) that (from https://forum.xanmod.org/thread-44.html):

- Set VM cache pressure value to 50%.  means vm.vfs_cache_pressure = 50
- Set VM swappiness value to 10%.       means vm.swappiness = 10
- Set VM dirty background ratio to 5%.  means vm.dirty_background_ratio = 5
- Set VM dirty ratio value to 20%.         means vm.dirty_ratio = 20

Is that correct?  I am asking because when I run "sysctl -a" in terminal, I actually see what I think are default values for vm.dirty_background_ratio and vm.dirty_ratio, which carry values of 10 and 40 respectively.

I would have expected to see vm.dirty_background_ratio = 5 (not 10) and vm.dirty_ratio = 20 (not 40) if I am looking at this correctly, whilst running the 4.11.6-xanmod9 kernel.

I had previously (well before ever hearing about xanmod) set in sysctl.conf my own values of vm.dirty_background_ratio = 2 and vm.dirty_ratio = 15, but as I have just learned today, those values have never been used (now that I am aware of the "sysctl -a" command).

So it seems ubuntu is using some default values instead of those dictated by the 4.11.6-xanmod9 kernel.  Is anyone else seeing this?

Is there a way to force my system to use vm.dirty_background_ratio = 5 and vm.dirty_ratio = 20, for example?

Cheers!

EDIT: perhaps it is a bug in ubuntu due to pm-utils? (https://bugs.launchpad.net/ubuntu/+sourc...ug/1407818)

Print this item

  can't connect to network drive 4.11.6-xanmod9 x86_64
Posted by: GWD72 - 20-06-2017, 09:47 AM - Forum: General Discussion - Replies (9)

Hello forum followers!

I am running Ubuntu LTS 16.04 and the xanmod 4.11.6 kernel (and loving it!) but have just found my connection to my netdrive is giving this error:

Oops! Something went wrong.
Unhandled error message: Failed to mount Windows share: Invalid argument

I confirmed this also on my wife's laptop.  Reverting back to the generic environment, currently on the 4.4.0-81 kernel, I can successfully connect to my net drive.

Please fix!!   Big Grin

Print this item

  i5-2410 no turbo xanmod 4.4-71
Posted by: GWD72 - 15-06-2017, 05:42 AM - Forum: General Discussion - Replies (7)

Hello forum followers,

I am new here, and after searching for my problem I found nothing so here is my post.  Apologies in advance if this should go to bug reports!

I run ubuntu 16.04 LTS and decided to try xanmod 4.4.-71 LTS with my HP 2560p running an intel i5-2410.  This CPU is standard 2.3 GHz with up to 2.9 GHz turbo.

When running with the 4.4-71 kernel, turbo is not available!  I see no higher CPU frequencies than 2.3 GHz.  For now I have unistalled everything and reverted back to the current native kernel (4.4.0-79-generic x86_64) but I would really like to try this xanmod and find out for myself how much better bfq is!

I can find nothing about this issue anywhere!  If anyone might have insight as to why this is a problem, please share.  I am willing to experiment to get it working!  My system is customised heavily and it could just be that some tweak I have made in the generic environment is messing up the xanmod environment.

An additional note that the update to the intel microcode installed a 2016 version, when if you go to the intel pages, my CPU microcode is from 2015.  I replaced the original microcode (3.20150121.1) from 3.2016.1104.1 (which I removed), but that did not solve the issue.

Edit: here is the read out from lscpu |egrep "Model name|MHz":

with xanmod kernel:

Model name: Intel® Core™ i5-2410M CPU @ 2.30GHz
CPU MHz: 2300.000
CPU max MHz: 2301.0000
CPU min MHz: 800.0000

without xanmod kernel:

Model name: Intel® Core™ i5-2410M CPU @ 2.30GHz
CPU MHz: 831.593
CPU max MHz: 2900.0000
CPU min MHz: 800.0000

Print this item

Online Users
There are currently 11 online users. » 0 Member(s) | 11 Guest(s)