Not a member yet? Why not Sign up today
Create an account  

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
ACPI BIOS Error (bug): \_SB_.PCI0._OSC: with Xanmod kernel HP Mini 210

#1
Hello forum followers:

I am running a HP Mini 210-1023eo with xanmod 4.11.12 and see this boot message each time I boot: ACPI BIOS Error (bug): \_SB_.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4

Thing is, everything runs beautifully, and this mini absolutely flies, and more so since I changed lubuntu 16 to run with the xubuntu desktop.

I do NOT see this error message running the lastest generic kernel 4.4.0-93 (is it?).

There is a bug report dealing with this error, but no solution is given: https://bugs.launchpad.net/ubuntu/+sourc...ug/1249244

In principle, I could care less if there is no damage done to the hardware.  My concern lay in that the motherboard of this Mini 210 died a few weeks back (error message was also showing with that MB), and I have now replaced it, and all seems fine except for this message which only appears using xanmod kernels (at least for me).

The original MB was old (2009) and the mini can get hot, so I do not think its demise is really related to this error message, but, I also don't know that for sure.  I don't want to kill this new one either!

Anyone else seeing this message?  If so, have you found a fix?

EDIT: same behaviour on 4.9.13-muqss and 4.12.10 (which incidentally hangs with this message on boot and has been removed).
Reply

#2
@GWD72

My system has booted with all flavours of XanMod from the very beginning, including beyond their limits with my own tweaking tricks, and no hardware problem was observed at all. Furthermore, I have not found information about possible motherboard damages booting a Linux kernel or any kind of damage with other available software. Anyway, there is two possible workarounds for your computer: 1) try to update the BIOS of the machine (probably not the best option because it could be some difficult task for newbies), and 2) try to disable ACPI while booting with ACPI=off at grub, a simply way imho for mostly all people. Please read the next links. Smile

https://askubuntu.com/questions/160036/h...en-booting
https://superuser.com/questions/1155458/...r-hardware
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#3
(31-08-2017, 12:09 PM)tropic Wrote: @GWD72

My system has booted with all flavours of XanMod from the very beginning, including beyond their limits with my own tweaking tricks, and no hardware problem was observed at all. Furthermore, I have not found information about possible motherboard damages booting a Linux kernel or any kind of damage with other available software. Anyway, there is two possible workarounds for your computer: 1) try to update the BIOS of the machine (probably not the best option because it could be some difficult task for newbies), and 2) try to disable ACPI while booting with ACPI=off at grub, a simply way imho for mostly all people. Please read the next links. Smile

https://askubuntu.com/questions/160036/h...en-booting
https://superuser.com/questions/1155458/...r-hardware

"ACPI=off" - already did that (message went away but upon login I had no wifi, battery was not recognised etc), as well as playing with other grub boot options found here: https://01.org/linux-acpi/documentation/...cpi-issues, stopping after "atpci=noacpi" since with that I could not even log in.

I can try the v24 (from v22 currently) in the bios, and while a pain to prepare the stick in linux (I've done this countless times from windows and linux), it is not so difficult as you claim.

You have a mini, right?  Trying yourself turning off acpi and see how well it works for you!

Does anyone have a working solution, rather than obvious workarounds?
Reply

#4
@GWD72 

Please, notice that this is not a problem or bug related with XanMod Kernel itself.
It's also widely known around the net certain issues about Linux and HP machines.
Anyway, we provide as much help as we can, so it's expected to be received politely. 

* More related info:
http://lkml.iu.edu/hypermail/linux/kerne...01961.html
https://bugzilla.kernel.org/show_bug.cgi?id=195319
https://bugzilla.kernel.org/show_bug.cgi?id=195311
https://review.coreboot.org/#/c/19284/

Thank you very much for your interest.
Tropic.
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#5
Bios is updated to the final version and the error message persists.

It is related to xanmod, most definitely, because I do NOT see this error when switching to the generic kernel, as was stated in post #1.

I can live with this for now since it seems when the machine is working well, it is unlikely to suffer as a result (from discussion in the bug declaration in the original post).

Of course, if anyone knows a solution, I am all ears.

Cheers

PS: Yes, politeness matters!
Reply

#6
@GWD72

I'm glad to read that your system works well despite of this ACPI error. 
Thank you again for your interest. All feedback is kindly welcome.
Sleepy
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply



[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text contained within the image into the text box below it. This process is used to prevent automated spam bots.
Image Verification
(case insensitive)

Forum Jump:


Users browsing this thread:
1 Guest(s)