Not a member yet? Why not Sign up today
Create an account  

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
Dependency Conflicts [solved]

#1
Hi there,

I am running into dependency conflicts on Ubuntu 17.10 since the Xanmod repo bumped the various GCC packages to 7.2.0-18.

On my system, the problem seems to arise from libgfortran4, which requires gcc-7-base (= 7.2.0-8ubuntu3). This package gets installed as a nested requirement for e.g. virt-viewer.

There probably isn't much to be done from the Xanmod repo side, just thought I'd mention it in case others run into a similar problem.
Reply

#2
Hello @Josh, 
are you sure that the GCC problem is caused by XanMod kernel?  Confused
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#3
(20-12-2017, 10:24 PM)Josh Wrote: Hi there,

I am running into dependency conflicts on Ubuntu 17.10 since the Xanmod repo bumped the various GCC packages to 7.2.0-18.

On my system, the problem seems to arise from libgfortran4, which requires gcc-7-base (= 7.2.0-8ubuntu3). This package gets installed as a nested requirement for e.g. virt-viewer.

There probably isn't much to be done from the Xanmod repo side, just thought I'd mention it in case others run into a similar problem.

I fix this issue, thanks for the report Josh.
Reply

#4
(20-12-2017, 11:43 PM)tropic Wrote: Hello @Josh, 
are you sure that the GCC problem is caused by XanMod kernel?  Confused

Now the repository has the gcc-7 packages as well.
Reply

#5
(21-12-2017, 12:00 AM)Alexandre Frade Wrote:
(20-12-2017, 11:43 PM)tropic Wrote: Hello @Josh, 
are you sure that the GCC problem is caused by XanMod kernel?  Confused

Now the repository has the gcc-7 packages as well.

Yes, you're right. Probably I didn't notice because I have latest GCC PPA by Toolchain, I guess. 
https://forum.xanmod.org/thread-5-post-2...ml#pid2220

https://launchpad.net/~ubuntu-toolchain-...buntu/test
https://launchpad.net/~ubuntu-toolchain-...ubuntu/ppa
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#6
(20-12-2017, 11:57 PM)Alexandre Frade Wrote:
(20-12-2017, 10:24 PM)Josh Wrote: Hi there,

I am running into dependency conflicts on Ubuntu 17.10 since the Xanmod repo bumped the various GCC packages to 7.2.0-18.

On my system, the problem seems to arise from libgfortran4, which requires gcc-7-base (= 7.2.0-8ubuntu3). This package gets installed as a nested requirement for e.g. virt-viewer.

There probably isn't much to be done from the Xanmod repo side, just thought I'd mention it in case others run into a similar problem.

I fix this issue, thanks for the report Josh.

Yep, that did the trick! Thank you so much!
Reply

#7
Just to bring some more light over this topic, XanMod kernel 4.14 LTS is able to run softly in a plain installation of Ubuntu 16.04.3 with no GCC updating -- tested and verified at two different computers and Oracle VirtualBox 5.2.4.

Code:
:~$ gcc --version
gcc (Ubuntu 5.4.0-6ubuntu1~16.04.5) 5.4.0 20160609
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
:~$ uname -a
Linux 4.14.8-xanmod12 #1 SMP PREEMPT Wed Dec 20 13:49:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
:~$ cat /sys/block/sda/queue/scheduler
mq-deadline kyber [bfq-mq] none
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply



[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text contained within the image into the text box below it. This process is used to prevent automated spam bots.
Image Verification
(case insensitive)

Forum Jump:


Users browsing this thread:
1 Guest(s)