Not a member yet? Why not Sign up today
Create an account  

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
System freezes on kernels later 4.14.13

#1
Hello!
I play Heroes of the storm through wine(use playonlinux). When I run the game client on a kernel version older than 4.14.13, after a while the system stops responding, I reboot the reisub. But version kernel 4.14.13 or earler work perfect.
Reply

#2
UPD
Ubuntu 4.15 works perfect too.
My kernel parametrs:
scsi_mod.use_blk_mq=1 ipv6.disable=1 rootfstype=ext4 libahci.ignore_sss=1 raid=noautodetect selinux=0 nopti spectre_v2=off noretpoline
Reply

#3
The important thing is that the latest versions work fine and those unknown issues have been solved. Wink
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#4
Works default canonical version kernel, xanmod kernel don't work.
Reply

#5
(24-02-2018, 03:33 PM)Guest Wrote: Works default canonical version kernel, xanmod kernel don't  work.

I'm sorry for the misunderstanding, my bad!  Confused

Ok, let's try to solve the problem, first please try to boot with only one parameter at once to see if the kernel is able to boot with all of them separately. If all are able to boot, then add one more and try to boot, and then add one more and so on till all them are wrote (to see if any combination of them is causing failures). 

PS., scsi_mod.use_blk_mq=1 is already set by default in XanMod.
I think that the culprit is selinux=0  Dodgy
You can replace 'quiet' with 'verbose' for more info.
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#6
I tried to load a kernel without parameters, or by specifying them selectively.
I try enable verbose parameters, nothing interesting. I seen wine logs, nothing.  And i try change io scheduler,  it did not help.
After run game all cpu kernels load 100%.  The system comes to life in ~30 minutes idle time.
Reply

#7
(24-02-2018, 09:33 PM)Archi Wrote: I tried to load a kernel without parameters, or by specifying them selectively.
I try enable verbose parameters, nothing interesting. I seen wine logs, nothing.  And i try change io scheduler,  it did not help.
After run game all cpu kernels load 100%.  The system comes to life in ~30 minutes idle time.

Then the most probable culprit is PDS CPU scheduler v0.98i. 
According to @Alexander' registry of changes for 4.14.14:
https://dl.xanmod.org/4.14/Changes-4.14.14-xanmod19
Code:
* ee2863a411f2 4.14.14-xanmod19
* 229d1ea06bb1 Tag PDS 0.98i
* ed81e4f43732 pds: 16ms dispersed balance interval.
* bdd9cdc346fa pds: Set default yeild_type to 1 and remove yield_to() support.
*   f9d0f3f8af1f Merge tag 'v4.14.14' into 4.14

However, actually the number of changes is so high that the newest way to register them with a link is difficult for me (here you can see main features with the old way https://forum.xanmod.org/thread-44.html and also the new one).  Mainly for this reason, I can't sure you which change could be mostly the culprit, but imho it should be the main change of PDS from 0.98h to 0.98i (just remark that 0.98h is the default PDS version since kernel 4.14.9 to 4.14.13 rev. 2, w/ eight kernels in total). If I am right, v0.98i is still the latest merged PDS CPU scheduler for 4.14.14 and newer XanMod LTS kernel series. So please wait for @Alexander answer if he considers to point better some workaround or upcoming solution to fix your problem. Thank you very much in advance for your interest in XanMod kernel. Smile
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#8
Yes, I think that this is so.

Kernel 4.15.4-xanmod5 have Tag PDS 0.98k, but the problem remained.
Will wait. Tropic, thank you so much!
Reply

#9
(24-02-2018, 12:44 PM)Archi Wrote: Hello!
I play Heroes of the storm through wine(use playonlinux). When I run the game client on a kernel version older than 4.14.13, after a while the system stops responding, I reboot the reisub. But version kernel 4.14.13 or earler work perfect.

How long is "after a while"?
What wine version are you using with HoS? HoS being a blizzard game would probably need "staging" branch. Officially the "staging" branch is dead, but there is a un-official one that may be able to patch latest wine-3.3 version, but all are "fiddly" and you would need to compile wine yourself.

Other than that i guess you are on the wine-staging-2.21 branch (newest release)?

I also did some testing and found setting /proc/sys/kernel/yield_type to 0 help a bit with wine performance for PDS scheduler.

In general wine should not be able to hard-lock your linux kernel, but having all cores at 100% would seem like it has "stopped responding". Can you ping the box, or ssh in to it when it happens?
Reply

#10
CybDex, the computer freezes at the time of the game loading. I use 2.21-staging wine version.
The system responds to the ping, but does not connect on the SSH.

UPD
Set yield_type to 0 sloved my problem. What does this option affect?
Reply

#11
(04-03-2018, 12:50 PM)Archi Wrote: CybDex, the computer freezes at the time of the game loading.  I use 2.21-staging wine version.
The system responds to the ping, but does not connect on the SSH.

UPD
Set yield_type to 0 sloved my problem. What does this option affect?

Sorry for the delay to answer, I was busy testing latest kernels.
Please @Archi read this very interesting and useful info from
admin and compiler @Alexander, available at his post about 
MuQSS and PDS Tuning Parameters:

https://forum.xanmod.org/thread-201.html
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#12
tropic, CybDex thank you very mutch for your help!
Reply

#13
(05-03-2018, 04:21 PM)Archi Wrote: tropic, CybDex thank you very mutch for your help!

Np Smile

Not really sure, but the multithreading in wine is somewhat.. well.. non-technical term: Weird :Smile

I think, without knowing, that wine sometimes can get somewhat caught up in some sort of thread-loop, and with "yield_type=1" PDS scheduler tries to "boost" the most active thread for "quick response", but since the thread might be caught in some sort of loop, this just makes stuff "locked". "yield_type=0" i guess just disables this "feature", and you dont have the same problems, as the scheduler will make sure threads and processes turn over in a more steady manner.

My attempt of a non-technical explanation of this, but feel free to correct me if im totally off.

I blame this problem to wine tho, as there are absolutely no problems having "yield_type=1" (default) when compiling with -j8 in the background while surfing and watching youtube videos++ Smile
Reply



[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text contained within the image into the text box below it. This process is used to prevent automated spam bots.
Image Verification
(case insensitive)

Forum Jump:


Users browsing this thread:
1 Guest(s)