Not a member yet? Why not Sign up today
Create an account  

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AMDGPU (RX 560) + Ryzen 5 Black screen boot

I am trying to use Ubuntu 18.10 with Xanmod but i am getting a black screen on boot... there is light coming from the monitor and it's recognizing some sort of black screen signal however. 4.15 from 18.04 and 4.18 from ubuntu 18.10 both seem to work fine however. (Just noting that (antergos, solus, and other versions of ubuntu) using a kernel newer than what seems around 4.18 have the black screen issue too.  (I've tried Xanmod 4.19 LTS, Xanmod & Vanillia 4.20.4, and 5.0 RC-3 so far))

The computer was recently built with a Ryzen 5 2600 and a RX 560. The motherboard is a MSI B450M Gaming Plus... I don't think it's the hardware that is the problem as i tested the computer with a GT 710 as well and everything worked fine graphically and physically (Xanmod 4.20.4 on KDE Neon worked fine.).

Further, the reason i would like to use a newer kernel is that while pretty much everything works in 4.18, my audio does not work a hundred percent. Not only does discord not seem to want to pick up my microphone in 4.18, but there is some audio crackling and issues with volume control in chromium. (all of which were resolved with 4.20.4 when i was using the nvidia card). I am also unable to use some distros because they use the newest kernel after first boot and i run into this black screen.

This is the log here... Has anyone else experienced this? Any solutions?

I just did a bunch of testing... it seems to be any kernel above 4.19.8.

I'm assuming it was this change as this seems to be related to the error i get:

"Alex Deucher (2):
drm/amdgpu/gmc8: update MC firmware for polaris
drm/amdgpu/gmc8: always load MC firmware in the driver"

I tried a couple kernel parameters... but nothing worked so far, and i don't think it would help anyways... From what it seems like the kernel is erroring out because it can't find a certain part of that MC driver? The problem i have sounds identical to others on reddit, but they've said it was fixed with iommu=pt or =soft, which is not the case for me. (nor amdgpu_dc=0) (The kernels need a newer linux-firmware maybe?)

Hi Aberts10, you need the latest linux firmware package present in xanmod repository (version: 1.176).

apt show linux-firmware | grep Version

To get manually:

See also:

I have just tested the firmware... unfortunately it did not work.

I'd like to mention earlier to today i also tried firmware which didn't work from:

Heres a full kernel log:

At line 841 i believe is where the black screen issue starts

"Jan 27 00:00:40 brian-pc kernel: amdgpu 0000:1f:00.0: No more image in the PCI ROM
Jan 27 00:00:40 brian-pc kernel: ATOM BIOS: xxx-xxx-xxx
Jan 27 00:00:40 brian-pc kernel: [drm] vm size is 64 GB, 2 levels, block size is 10-bit, fragment size is 9-bit
Jan 27 00:00:40 brian-pc kernel: amdgpu 0000:1f:00.0: Direct firmware load for amdgpu/polaris11_k_mc.bin failed with error -2
Jan 27 00:00:40 brian-pc kernel: mc: Failed to load firmware "amdgpu/polaris11_k_mc.bin"
Jan 27 00:00:40 brian-pc kernel: [drm:gmc_v8_0_sw_init [amdgpu]] *ERROR* Failed to load mc firmware!
Jan 27 00:00:40 brian-pc kernel: [drm:amdgpu_device_init.cold.31 [amdgpu]] *ERROR* sw_init of IP block <gmc_v8_0> failed -2
Jan 27 00:00:40 brian-pc kernel: amdgpu 0000:1f:00.0: amdgpu_device_ip_init failed
Jan 27 00:00:40 brian-pc kernel: amdgpu 0000:1f:00.0: Fatal error during GPU init
Jan 27 00:00:40 brian-pc kernel: [drm] amdgpu: finishing device.
Jan 27 00:00:40 brian-pc kernel: amdgpu: probe of 0000:1f:00.0 failed with error -2"

Ok, the polaris11_k_mc.bin firmware is not present in the package.

1. Download:

2. Move as root in: /lib/firmware/amdgpu

3. Update initramfs for all kernels: sudo update-initramfs -u -k all

Works now! Thank you very much! I didn't update the initramfs

Quick Reply
Type your reply to this message here.

Image Verification
Please enter the text contained within the image into the text box below it. This process is used to prevent automated spam bots.
Image Verification
(case insensitive)

Forum Jump:

Users browsing this thread:
1 Guest(s)