Not a member yet? Why not Sign up today
Create an account  

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
Swap freeze

#1
Bug 
By a bug in a Telegram desktop program, the process consume all RAM but when the system suppose to do swap the system only freeze and the disk usage got to 100%. the system got unresponsive and I had to turn off.

When I do memory stress on the system whit last xanmod LTS kernel 4.19, the system got freeze and do only a few Megabytes of swap.
however when do the same whit the stock kernel 4.15, the system got slowdown until the swap is complete.

The comand for the test is:

stress --vm-bytes $(awk '/MemFree/{printf "%d\n", $2 * 1.2;}' < /proc/meminfo)k --vm-keep -m 1

My system:


Code:
Machine:   Device: desktop System: Gigabyte product: N/A serial: N/A
           Mobo: Gigabyte model: 970A-UD3P v: x.x serial: N/A UEFI: American Megatrends v: FC date: 02/26/2016
CPU:       8 core AMD FX-8350 Eight-Core (-MCP-) cache: 16384 KB
           clock speeds: max: 4200 MHz 1: 3533 MHz 2: 3130 MHz 3: 4219 MHz 4: 4236 MHz 5: 2823 MHz 6: 2890 MHz
           7: 3321 MHz 8: 4019 MHz
Graphics:  Card: NVIDIA GK208B [GeForce GT 710]
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia FAILED: modesetting Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GT 710/PCIe/SSE2 version: 4.6.0 NVIDIA 418.43
Audio:     Card-1 NVIDIA GK208 HDMI/DP Audio Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.20.0-13.1-liquorix-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: 40:8d:5c:86:55:36
Drives:    HDD Total Size: 620.1GB (64.7% used)
           ID-1: /dev/sda model: KINGSTON_SA400S3 size: 120.0GB
           ID-2: /dev/sdb model: WDC_WD5000AAKX size: 500.1GB
Partition: ID-1: / size: 110G used: 15G (14%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 427G used: 329G (82%) fs: ext4 dev: /dev/sdb2
           ID-3: swap-1 size: 34.39GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 35.5C mobo: 39.0C gpu: 50C
           Fan Speeds (in rpm): cpu: 3308 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0
Info:      Processes: 300 Uptime: 5:46 Memory: 4448.1/24070.7MB Client: Shell (bash) inxi: 2.3.56
Reply

#2
This has nothing to do with the kernel, contact the developers for the application.
Reply

#3
swap problem confirmed
Reply



[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text contained within the image into the text box below it. This process is used to prevent automated spam bots.
Image Verification
(case insensitive)

Forum Jump:


Users browsing this thread:
1 Guest(s)