Not a member yet? Why not Sign up today
Create an account  

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
Enable "CONFIG_DRM_AMDGPU_CIK=Y"?

#1
In order to use AMDGPU on GCN 1.1 cards, you have to enable the experimental support through the AMDGPU driver (amdgpu.exp_hw_support=1), blacklist the radeon kernel module, and have the support compiled within the kernel (CONFIG_DRM_AMDGPU_CIK=Y).

By-default, both options above are disabled and radeon is chosen. If CONFIG_DRM_AMDGPU_CIK=Y is set, this should not cause users of GCN 1.1 cards any issue since AMDGPU won't be enabled still without manual intervention (amdgpu.exp_hw_support=1, and blacklisting radeon).

So, basically I would like to request the setting of CONFIG_DRM_AMDGPU_CIK=Y for future XanMod kernels. I'm not entirely certain if there is anything else needing done beside that (the Arch Linux page only mentions the above things), but this Gentoo page mentions some other things too.
Reply

#2
Thanx for the tip here, might help some  . Glad to see new people around !
Reply

#3
Espionage724, thank you for your proposal that has been added to the 'Short ideas for Xanmod kernel' section. Please, get a warm welcome to the forum and enjoy the site. Big Grin
"(...) the grandest occasion the past or present has seen, or the future can hope to see." -- Cervantes.
Reply

#4
There is also CONFIG_DRM_AMDGPU_SI that enabled amdgpu driver for GCN 1.0 parts.
Reply

#5
Thank's for tips.
Reply



[-]
Quick Reply
Message
Type your reply to this message here.

Image Verification
Please enter the text contained within the image into the text box below it. This process is used to prevent automated spam bots.
Image Verification
(case insensitive)

Forum Jump:


Users browsing this thread:
1 Guest(s)